Jump to content
  TPR Home | Parks | Twitter | Facebook | YouTube | Instagram 

Recommended Posts

2 minutes ago, robbalvey said:

Yeah, I'm not sure what to do.... those three photos above were:

1. Normal camera phone held correctly.

2. Normal camera phone held upside down

3. Selfie camera.

I'm using an iPhone 11 Pro.

I can't seem to reproduce the photo orientation incorrectly problem.

I wish I could do more about this, but I'm not sure how to fix it.

oh, no worries!   Was just letting you know that I saw the same thing from the other day.

once I found the "fix" - and I repeated it with every pic that had uploaded incorrectly, then just dropped the "fixed" images in place of the wrongly oriented one.

so there's a workaround on the Poster's end (at least workaround for me). . so I'm not concerned.   Was just letting ya know!

  • Like 2
Link to post
Share on other sites
  • Replies 163
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Would you believe it?  After 15 years of the TPR forum being online, we finally updated it!!!  We hope many of you will love the more streamlined look, improved functionality, and new features. 

This place is loaded with lurkers who don’t post (PS: You should post, only a few of us bite). I feel like the new post reactions are the moment they’ve been waiting for. 🤣

Looks really good on the computer! Love the modern look but with the same forum layout/sections we all know and love. Makes the transition easy for the user. Love the new features you shared, esp

Posted Images

just to show example:

Both of these picss are showing correct orientation on my iPhone, and on my desktop - since I move pics over to do TRs on my desktop system (my preferred TPR platform).

the top one is an untouched pic

the bottom one was opened via Photo Editor, opened the Crop/Rotate option, and "flipped" the pic to reverse it. .then flipped it back and saved as the same name.  and that one loaded fine.

so there's a way around it for me, but just to give the example :)

 

Test2.thumb.JPG.8a01b0dcd8dae3e56cfcdb6b3fba03f7.JPG

BKWI2284.thumb.JPG.7d4fac568c34537543ba589e34cf4e80.JPG

  • Like 1
Link to post
Share on other sites
12 hours ago, bert425 said:

just to show example:

Both of these picss are showing correct orientation on my iPhone, and on my desktop - since I move pics over to do TRs on my desktop system (my preferred TPR platform).

the top one is an untouched pic

the bottom one was opened via Photo Editor, opened the Crop/Rotate option, and "flipped" the pic to reverse it. .then flipped it back and saved as the same name.  and that one loaded fine.

so there's a way around it for me, but just to give the example :)

 

Test2.thumb.JPG.8a01b0dcd8dae3e56cfcdb6b3fba03f7.JPG

BKWI2284.thumb.JPG.7d4fac568c34537543ba589e34cf4e80.JPG

I had the exact same issue with my latest trip report from Tripsdrill which I did on the old forums. I shot my pics with my Nexus 3XL. Some (!) untouched pics were upside down. If I opened them with paint, did nothing else but saving them again directly, they were displayed correct. I haven't done my trip report from Holiday Park last week, but I'll have a look if it happens here again.
It looks to me more like a problem with how the phone cameras are saving the pics and not with the forum software itself.

  • Like 1
Link to post
Share on other sites

^ That is correct and somewhat annoying. Being a web developer, I've come across this on many websites I've worked on.

Long story short, within JPG files there is a EXIF data flag for "orientation" which are values 1-8, the common values being 1 (no rotation), 3 (rotated 180°), 6 (rotated 90°) and 8 (rotated -90°). Essentially your camera (and it's sensors) always take photos in one static direction, but based on the accelerometer in the device it will flag it for orientation differences.

Some image programs naturally observe this and display it in it's intended orientation when viewed on screen, but browsers (and web applications), typically show it in the original form without checking against the flag.

Easiest way to rectify this is (by the user) usually opening the images in a photo editor which usually will interpret the flag and show it to you correctly and when you save/re-save the image, it will save it in the way it is displayed on your screen with the orientation flag set to "1" by default.

It can be handled on the server end by checking the file and manipulating it on upload, but I'm not entirely sure how Invision board uploads are handled, but I assume there is either a plugin or add-on that exists for it, or it could be updated manually. Willing to help if it's at all desired.

  • Like 1
  • Thanks 2
Link to post
Share on other sites

Haven't had much time to explore the new format, but I can see ALL THE EFFORT THAT WENT INTO IT!   Thanks a million, Robb,  (and to any 'elves' that may have assisted you).  🧙‍♀️🧙‍♂️  I hope to get started ASAP to begin my explorations of 'TPR 101.'  🕵️‍♀️

  • Haha 1
Link to post
Share on other sites
  • 2 weeks later...

image.thumb.png.627719234c9066a2d0ecad335fc31510.png

image.thumb.png.0e44a0a348fe8fb77b1ae2d58630c1a1.png

 

Bit of a random issue and easily worked around by using the main forum so wasn't sure if you wanted it reported but just in case... I've noticed some threads that I posted in, don't show up in the 'content I posted in' activity thread. I thought it might be the date so I changed it from last 365 days to anytime but they still don't show up.

 

Granted the example here is Marineland so I'm probably not missing much skipping over it.

Link to post
Share on other sites

The only thing I'm "missing" is the link back to the front page (when I click on the TPR logo at the top of the page, it brings me the forums still - the old page used to bring me back to TPR front page, so could check out recommended posts, and see the active twitter feed).

 

minor issue - as I simply bookmarked TPR front page in addition to the forums.     But just noting it.

Link to post
Share on other sites

^ It's not as large at the main logo at the top, but you could click on "TPR Home" at the top right to go back to the home page.   It looks like this link is on the mobile version as well.

 

image.thumb.png.cf9a3c3f6abc134c25467a7c2804c53b.png

  • Like 2
Link to post
Share on other sites
1 hour ago, bert425 said:

The only thing I'm "missing" is the link back to the front page (when I click on the TPR logo at the top of the page, it brings me the forums still - the old page used to bring me back to TPR front page, so could check out recommended posts, and see the active twitter feed).

Yeah, sorry... this was by design.  We found that more people needed to get back to the forum home than the front page home, so that's why the top logo links back top the forum home.  As mentioned above, there is now the link to the TPR Home Page that should appear on ever page of the forum.

Also, if you're in the forum home, at least on the desktop version, we have put the most recent Twitter feed as there as well. Scroll down a bit on this page: https://themeparkreview.com/forum/

  • Thanks 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...

Important Information

Terms of Use https://themeparkreview.com/forum/topic/116-terms-of-service-please-read/