Jump to content
  TPR Home | Parks | Twitter | Facebook | YouTube | Instagram 

Forum Image Multi-Uploader!

Recommended Posts

Hey everyone! We have added a new feature to the forum that we could use a bit of help testing out. Starting today, you should see this at the bottom of the screen where you can attach a file:


You now have the option to attach a single image file, or you can now select multiple files from your hard drive directory or your iOS Camera Roll.


Please note the following instructions:

1. Click the "Browse" button to access your hard drive or iOS Camera Roll.

2. Select the files you want to upload.

3. Keep in mind that the files will be uploaded in the order they are named. So if you are working on a trip report, be sure to label your files "rollercoaster_1.jpg", "roller coaster_2.jpg", "roller coaster_3.jpg", etc, etc...

4. Click "Add Multiple Files."

5. Once you have done this, it will bring you into the "preview mode" where you can add captions, change the order that your files will appear, etc

6. When you are ready to finalize your post, we STRONGLY recommend clicking "Preview" again, just to make sure everything looks correct, and then...

7. Click "SUBMIT!"


A few additional notes about the multi-uploader...


1. If you are uploading from an iOS device (iPhone, iPad, iPod, etc), you MUST check the "Uploading from iOS device" box, otherwise only one of your images will be uploaded!


2. We have added a "Place all Inline" button for those of you who like to add additional content inbetween your images (YouTube videos, Vine Videos, more text with URL's, etc, etc...) Again, we STRONGLY recommend clicking "Preview" to make sure your photos, captions, and other content are appearing correctly.


3. You can upload 25 images at a time. You can have more than 25 in one post, but you can only upload 25 at one time.


4. We have spent a few weeks testing this on our test forum, but we are still working out any bugs. If you notice anything that is not working, please report them IN THIS THREAD!


That being said, we would love to see some new trip reports or photo updates posting using this new system! Please test it out and let us know what you think of this new feature!


Thank you everyone for your help!



Edited by robbalvey
Link to comment
Share on other sites

  • Replies 133
  • Created
  • Last Reply

Top Posters In This Topic

EDIT: just one note, during preview my pics where showing up reversed.

Yep, just noticed that. It was fixed in the test environment and that seems to have gotten missed when it went live. Fixing now...

Edited by robbalvey
Link to comment
Share on other sites

I just used it now, on my latest TR posting, Robb.

(And I uploaded 17 photos.)

Worked perfect, for me. No prob at all.


EDIT to add: For myself, one of the best parts of this

new system, is that I can now change the order of the

photos, in Preview mode. Great!

Link to comment
Share on other sites

Sorry for the double post. This round I am attempting the multi uploader on the computer and seems to have worked flawlessly! I was initially concerned on how we'd caption our photos but see that it gives us thumbnail previews of the uploaded images. My SFMM trip report (long delayed) should now be a breeze!


I did notice that it did not put my images in order by name but I do see the boxes where we can put what order the images are to be. I like the fact that I can rearrange my photos as in the past I have accidentally skipped a photo and had to do an "oops, forgot this pic" to my report.











My #1 steel!

Link to comment
Share on other sites

Test from my Android.


Results: I wasn't able to upload a batch of photos, just one photo at a time. But that may be because my phone doesn't really allow me to choose multiple photos. This is an improvement, though; in the past, I couldn't upload photos from my phone to the forum at all.


Now that's a steak.


Sunflower in a storm drain.

Edited by cfc
Link to comment
Share on other sites

^^I had actually messed with the picture ordering afterwords, trying again with another, this time a sequence/series. It appears to be in order.

*Light bulb turns on above head and realized something of my doing*

Here's what happened, which I'm at fault for. I had named my photos "kbf-sfmm_#" and the next one uploaded was "kbf-sfmm_###." Had I stuck with triple digits all the way through my initial renaming sequence (001, 002, etc) they would have been in order. The first 2 images had a single digit in its file name and stuck them at the end...much like in my Explorer. So yea, to me


This series of photos work due to the fact that the number section on these consist of a set of 3 digits.


Looking ahead, when I do my trip report (and future trip reports), I'll have to batch rename my photos so that I can keep them in order.







Edited by Angry_Gumball
Link to comment
Share on other sites

Okay here's my test from a MacBook Pro. Pictures from Port Aventura from my Spain 2012 trip. The Multi Uploader only let me upload one picture at a time, but it let me rearrange the uploaded pictures in any order I wanted which is a huge +. I will have to test uploading from my iPhone 4S soon enough to see how that works out.


#5 Dragon Khan in front of its new neighbour


#3 Shambhala is next


#1 We rode this first


#2 Wait times after we got off Furious Baco


#4 We are heading there


#8 Shambhala and Dragon Khan living in harmony in the background. I'll have to post my Spain 2012 TR soon enough.


#6 This has gotten really rough (especially Stampida on the left side of this pic)


#7 One of my favorite drop rides

Link to comment
Share on other sites

The Multi Uploader only let me upload one picture at a time.

Are you SURE you are using the "Multi-Uploader" and not the "Single Uploader?" I'm on a Macbook Pro too and the multi-uploader is working just fine for me in Firefox, Safari, and Chrome. We've already had one person report a problem that turned out to be user error, so before I go report this to our developer, can you please be SURE you are using the multi-uploader. You're the only person to have reported this being an issue, so until you can provide more details, I also have to assume this is user error.


Uploaded from a Macbook pro using the multi-uploader. Works just fine!


Uploaded from a Macbook pro using the multi-uploader. Works just fine!


Uploaded from a Macbook pro using the multi-uploader. Works just fine!


Uploaded from a Macbook pro using the multi-uploader. Works just fine!


Uploaded from a Macbook pro using the multi-uploader. Works just fine!


Uploaded from a Macbook pro using the multi-uploader. Works just fine!

Edited by robbalvey
Link to comment
Share on other sites

Another Test







Yeah, I'm finding no issue using the multi-uploader with a Macbook Pro so I have to assume you're doing something wrong.


If you're still having trouble, Andrew805, please record a video of the issue so I can see it and review what the problem seems to be.

Edited by robbalvey
Link to comment
Share on other sites

So, I played with the new multi-uploader, with a more complex update than most people have posted and ran into a bunch of problems.


I'm using Windows 7 and MS Internet Explorer 10, if that matters.


Here's the PTR update I posted, for reference.




So, the first problem I ran into is that the multi-uploader wouldn't accept any of my pictures!


Instead, after uploading everything (with the files and percentages visibly being uploaded and going through) it eventually gave me this failure notice:


Could not upload attachment to ./files/asia__12_-_days_18-20_-_chengdu_195.jpg.

Could not upload attachment to ./files/asia__12_-_days_18-20_-_chengdu_196.jpg.

Could not upload attachment to ./files/asia__12_-_days_18-20_-_chengdu_197.jpg.

Could not upload attachment to ./files/asia__12_-_days_18-20_-_chengdu_198.jpg.



At first I thought it was the long file names, or maybe the hypens in my filenames. But after a bunch of trial and error, it turns out that the multi-uploader doesn't like apostrophe's. The filenames were in the format of

Asia '12 - Days 18-20 - Chengdu 195.jpg

Note that when adding the files individually, there aren't any problems with apostrophes. I even added one manually just to check if it still worked.


Once I figured that out, I tried uploading pictures. It worked, but it paused for several minutes after it had said that the uploads were 100% done. Eventually, the first batch of pics was uploaded and ready, sending me into preview mode. But for some reason, it didn't give me the preview pictures themselves. Just the boxes with an X in them as placeholders for where the pictures should be. Not a big deal, though.


So, I uploaded the rest of my pictures. For some reason, it then renumbered all of the pictures I'd previously uploaded to #1 in the posting order, and numbered the latest pics I had added as 2, 3, etc, I figured that was just a glitch that didn't matter. After uploading some more pics, I only had a few with higher numbers, and everything else was 1. I went to preview my post, and all of the pictures were out of order, in random order, other than those ones with the 2, 3, etc, which were at the end. So, I had to reorder them and manually change every single number! After I did so, everything posted correctly.


So, apparently, when you add further groups of pictures, it resets all of the previous ones to 1. Which means that the person will now have to manually renumber every single picture into the right order. If not, they'll all get posted in a random order, since it thinks they're all supposed to be first.


In short:

-- apostrophes are not allowed in filenames for the mutiuploader

-- there aren't any picture previews in the preview page

-- if uploading more than one batch of pictures, ALL of the posting order numbers have to be manually changed.


I hope this helps.

Link to comment
Share on other sites

^ That's actually helpful information. Yeah, apostrophes are really troublesome and I highly recommend people not ever use them in filenames. EVER. As for the other issues, I'll have to check and see if they are an issue because of the apostrophes throwing the system off or a real issue. But this is helpful information.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...

Important Information

Terms of Use https://themeparkreview.com/forum/topic/116-terms-of-service-please-read/