Jump to content
  TPR Home | Parks | Twitter | Facebook | YouTube | Instagram 

Official RCT/RCT2 Help Thread


Recommended Posts

I've got a small problem. I downloaded 2 things from NE, Basics of My Brain by cbass and Nitro by Phatage. I opened Basics of My Brain and took a look around at everything just fine, but when I went to load Nitro, the flashing loading bar came up, and I had to restart my computer. I've already deleted both from my files and from the saved games folder under RCT2, but the game still won't start. Any ideas? Thanks.

Link to comment
Share on other sites

^What you have is a bad file in your objdata folder. One that is conflicting with another or just plain bad causing the game to read invalid data. If you made a backup of your objdata file the easiest thing to do is just remove the one with the issue and replace it with your backup. If you have the DataChecker utility you can use it to check your folder for any bad DATs and remove them. They will have RED or YELLOW flags in front of them. Removing these flaged items may or may not solve the problem.

 

If the options above don't work then try the next two options. They are not so easy. If you know what new files came from the park remove them and load them back in a few at a time till you find out which one is the bad file. Last resort take your bad objdat folder and make a copy and put it on your desktop. Make backups of your tracks folder, scenarios folder and saved games folders and put them somewhere safe. Uninstall RCT and what ever expansions you have. Re-install the game and put your saved folders back in but do not put the bad objdata folder back. Once have everything back where it belongs start loading in all the objects from your bad objdata folder one section at a time. Sort them by name and load back in all the A's and start your game to let them load in, then all the B's and start your game again, Rinse and repeat until you have everything A to Z back in your game. While copying the files back into the games objdata folder it will ask you if you want to replace files with versions from where your are copying them from. HIT NO! Do not replace any items! You will have to hit NO over and over again! When your load a "LETTER" group and the flashing load bar of death comes back you will know what letter it starts with. Remove them all and load them back in 10/20 or so at a time till you find the ONE problem DAT. Sometimes you will be able to load them all back in and never find the problem DAT. That is because when you hit "NO - do not replace" you stopped the bad DAT from taking the place of the good one and the problem was stopped before it started.

 

Hope this helps.

DatChecker.zip

Link to comment
Share on other sites

I'm still having the problem of the disappearing train type however I've started using 8 Cars version 1.21 and it's the only one where it will show up and not crash my game. Oh and do rides in cold weather happen to crash more frequently? I've been playing the Arctic scenario from WW and every roller coaster I've made seems to crash which is odd because I have the same ride running on a different scenario and never had it crash...

Link to comment
Share on other sites

^Cold weather should have no effect on the games rides. When you say crash do you mean a brake failure crash?, or trains valley-ing and being struck from behind or both? In either case if you run the rides in block brake mode they will not crash. You will need to change dispatch times and or reduce the number of trains to keep them running efficiently.

 

Ride break downs are random acts, weather has no effect. Age however does. With that said a station brake failure can happen at any time even if the ride is new. The only defence against is to have a mechanic assigned to the exit of any coaster that arrives into the station at a fast pace. If he gets the call fast enough he can fix it before the crash happens.

Link to comment
Share on other sites

It's a 2 train hyper twister and I'm not sure why it does it. The first time it crashed was on a chain lift about 2-3 minutes into the ride. It was a safety cut-out where the first train was situated and stopped towards the top of the lift, the other came up from behind it and crashed right into it. I'm kinda baffled as how the ride, which before the lift, runs at about 40 mph, and all the lift has is need for is just to clear the hill. The second time, they crashed as they were going into the station... again, still worried about that.

 

And I set up a place holder pre-designed Penguin Slide as I started building around the park, and within 5 minutes of me putting it up, it crashed. No breakdown or anything, just a crash.

Link to comment
Share on other sites

^All three versions of 8cars should be fine, I use them myself. I think I'm the one who uploaded them here right off my computer. You have to remember these trainers were never intended to be used on systems running Vista, or Windows 7. Those systems were not around back then. I am running XP and I can set any program to run on any version all the way back to 95. I would think you should also be able pick what version to run it on. If Windows 7 will let you right click on the icon for 8cars and hit properties. From there find the compatibility tab and set it to XP or earlier. If you can set it to an earlier version and it is still crashing out your game try setting the game itself back to run on an earlier version of Windows.

 

Please let me know if it works so I can pass it on to others if the question comes up again.

 

^^ The only thing I can think of is that while you were using a trainer you hit the wrong ride and changed it's settings causing the second train to launch, giving it the speed it needed to hit the other one stuck on the lift. As mentioned before the best way to keep coasters from crashing in RCT2 is to treat them like "real coasters" and use block brakes and if there is no way to get block sections onto the ride use only one train. I even use Block Brake Mode on coaster versions in the game like Side Frictions that don't offer it by setting the mode using 8cars. With the use of 2 stations and one lift hill you can get 2 trains on any type of coaster even if that type doesn't have block section track pieces. If you don't like your coaster trains sitting at the top of lifts waiting for the other train to finish it's course set the dispatch time so it doesn't happen. Once again, set it up like a real coaster would be.

Link to comment
Share on other sites

^ That was the first thing that I tried to do but it took an hour to find were to change it because there is no compatibility tab when right clicked. I changed it to XP and tried again and nothing changed. Tried to merge and 8cars crashed and the game still ran on like nothing happened. I even copied 8cars and tinkered with it myself in the program itself, nothing I did worked. I deleted the muntant programs that I had changed and kept the originals but I guess Im going to have to deal with no merging until an 8cars comes out for Windows 7. Thanks for trying to help though.

Link to comment
Share on other sites

Just want to toss this out here for anyone interested, there is a site called The Definitive RCT Reference Guide and it has all kinds of information about RCT. If you want to know why you can't get the ratings up on a Swinging Ship even though you put all kinds of scenery around it the explanation for it and all other rides is available from the site. Ever want custom music for you Carousel or Dodgems? Well you can find things like that also.

 

The site is aimed at RCT and it's two expansions CF & LL but 99% of the information is the same for RCT2.

Edited by dmaxsba2408
Link to comment
Share on other sites

^^

 

First off, I'm new here, but I do have one question. I am currently running on Windows Vista and I can't seem to find my screenshots I have taken. Does anyone know where to locate them?

 

Go to the screenshots folder and at the top of the window, there should be a "Compatibility Files" button. Press it. Photos magically appear.

 

Anytime you don't see files where they should be, chances are they are just in the Compatibility Files area. It's Vista being more complicated than it's supposed to be.

 

[the actual location of the Compatibility Files section is extremely obscure...which sucks]

Link to comment
Share on other sites

Something weird with the screenshots on vista, some of them actually started showing up without pressing Complatibility files. I don't remember doing anything different, but for 100 screenshots or so I didn't have to go to compatibility files. Now I'm back to the same-old, same-old.

 

Weird.

Link to comment
Share on other sites

How do you access RCT2 screenshots in Windows 7?

 

I have done it in the past but cannot remember how I got them, it says the screenshot has been taken but there is nothing in the RCT2 folder.

 

There are in your RCT2 folder. Like were you have to go to see the Object Folder. They should be at the bottom of the folder. That is were I found all of mine.

 

You do not have to do anything with "compatibility". Just go to the folder.

 

Hope that helps.

Link to comment
Share on other sites

^ Most likely it is an issue with the lift track, you need to remove the cable lift from the top of the hill and replace it.

 

What is happening is that there is a section of cable lift track missing somewhere on the hill causing the game to error trap. When you remove a section of cable lift hill there is no way to replace it unless you re-build the top of the lift. When you do that the game replaces it automatically.

Link to comment
Share on other sites

This isn't really a question or problem in rct2, but a question that is about an rct2 park, so I think it fits best here. A couple of years ago, I found this park at the AtariCommuntiy website, and I know it's probably still there but I forget its name. I don't know if any of you have ever seen it, and I don't want to bug you or anything. The few things I can remember is that at the entrance, there were white walls to represent a blank canvass, there was a medival castle section, a jurassic section with the start of a black coaster, and a mining town section with a huge mountain and rollercoaster, and that in the middle, there was a huge lake with a path going the perimeter. If any of you have seen this, please tell me. It's been irking me for a couple of days now. THANKS!!!

Link to comment
Share on other sites

This isn't really a question or problem in rct2, but a question that is about an rct2 park, so I think it fits best here. A couple of years ago, I found this park at the AtariCommuntiy website, and I know it's probably still there but I forget its name. I don't know if any of you have ever seen it, and I don't want to bug you or anything. The few things I can remember is that at the entrance, there were white walls to represent a blank canvass, there was a medival castle section, a jurassic section with the start of a black coaster, and a mining town section with a huge mountain and rollercoaster, and that in the middle, there was a huge lake with a path going the perimeter. If any of you have seen this, please tell me. It's been irking me for a couple of days now. THANKS!!!

 

Sorry, can't help you on that one.

 

I think I'll use this thread to vent I had done a MASSIVE amount of work on a park, but I'd never saved it. I was about to, but thought to myself I'd just wait until after I built a chairlift.

 

The game had other ideas, right when I clicked make a new chairlift, I got on error trapper

 

My game is seriously screwy!

Link to comment
Share on other sites

^

 

Although a slight annyonance, I suggest just saving before you build any coaster.

 

1. It prevents losing everything

2. If you don't like what you build and want to keep the old ride, all you have to do is restart the game and poof! Like nothing happened.

3. It's just a time saver in general.

Link to comment
Share on other sites

I totally agree, save under different names also, like park(a). park(b), park© and so on. So you always have a version of your park saved at different stages so you have something to fall back on if something really bad happens, like an error trapper loop and by that I mean you built something in the park and saved your game. Well right after you saved it error traps and now every time you load it it error traps as soon as it opens before your can remove the cause. Your park is lost forever!

 

Error trappers are RCT and RCT2 way of saying stop messing with me. I am not user friendly. The Drexler Patch solved most of the issues for RCT. No one has ever bothered to make a patch like that for RCT2. I wish I knew how to do stuff like that because whoever makes one will be the hero of RCT2 fans everywhere. Can you imagine how nice it would be to put cars that don't belong on a certain type of track and not have the ride breakdown every five seconds, or add a few extra cars to a coaster train and have it stay that way instead of always reverting back and so many other little things that were so common back in the days of RCT.

Link to comment
Share on other sites

^ Most likely it is an issue with the lift track, you need to remove the cable lift from the top of the hill and replace it.

 

What is happening is that there is a section of cable lift track missing somewhere on the hill causing the game to error trap. When you remove a section of cable lift hill there is no way to replace it unless you re-build the top of the lift. When you do that the game replaces it automatically.

Thank you!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

Terms of Use https://themeparkreview.com/forum/topic/116-terms-of-service-please-read/