Jump to content
  TPR Home | Parks | Twitter | Facebook | YouTube | Instagram 


Recommended Posts

  • Replies 182
  • Created
  • Last Reply

Top Posters In This Topic



I've gone to the page in your store that says "free Download." When I click on the "free download" link I'm taking to the page but there's no "add to cart" button. When I click on the DVD title I'm taking back to the same page only this time below the price (which says $0.00) it has a note that says "In stock: no." Has this been removed or is the site having problems?


Thanks for your help.

Link to comment
Share on other sites

I tried downloading it 3x and keep on getting corrupted error message. So I switched to XP and got "Access Denied" and then I went back to the store to re-request the link and now it isn't in the stock. Hmm...


I kept getting that corrupted error message to on my Vista computer.


When I switched to my XP computer I used the same link provided in the e-mail sent to my Vista computer and it worked fine. Give that a shot. I just tried it again over here to see if it still works and it does.

Link to comment
Share on other sites

I am having trouble with this free download all day.

I have allready tried to download it 3 times, but i never got a downloadlink in my email. Not even in the spam folder.

The 4th time i wanted to try it the "Add to cart" button was gone.

What happend your website Robb??

Link to comment
Share on other sites

Well, Dave, you've gotten me farther than I've been the whole day... however...


C:\Documents and Settings\Danny Smith\Desktop\rebuilt.TPR_Coaster_Expedition_Vol_1.zip: CRC failed in TPR Coaster Expedition Vol 1.mp4. The file is corrupt


Dan "I wish I weren't so electronically-challenged!" Smith

Link to comment
Share on other sites

Damn it! It didn't work for me! I got this message:


C:\Users\Tatum\Desktop\TPR_Coaster_Expedition_Vol_1.zip: The archive is either in unknown format or damaged


Anyone else get this message?




I got that exact message twice. I then downloaded it on my older computer that has XP and not vista and it worked perfectly.


Verdict: Vista screws stuff up.

Link to comment
Share on other sites

I've managed to get a link, but it won't download past 40Mb. There is plenty of space on the computer for the file so I don't know whether I am doing something wwrong or not.


Has anybody got any suggestions?


if it helps, I am using XP


Thanks in advance,



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...

Important Information

Terms of Use https://themeparkreview.com/forum/topic/116-terms-of-service-please-read/